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Tel 561 779 5660.Email Info@Datexel.com www.Datexel.com

User GuideUser Guide
DAT11130PN

PROFINET IO SLAVE  – 4 DIGITAL INPUTS AND 4 RELAY OUTPUTS
GENERAL INFORMATION

INPUT / OUTPUT DATA OBJECT STRUCTURE

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Descr MSB - - - - - - - - - - - - - - LSB

Byte HB (1 byte) LB (1 byte)

Meaning:
MSB → Most Significant Bit
LSB → Least Significant Bit
HB → High Byte
LB → Low Byte

The Input / Output objects are represented in Unsigned Integer 16 bit format.
For Unsigned Integer 16 bit format, the values are composed of 2 bytes ordered as represented in the Structure 1 below.
The range of value is between 0 and 65535.
If the value of a data is used to represent a number for which it is foreseen the sign (i.e. analogue input measure) it is necessary subtract 65536 from 
the read value to obtain the true signed value. Refer to the description of the single object to know the number of decimal digits.

Vendor Name: Datexel S.r.l.
Vendor ID: 0x078B
Device Name: DAT11130PN
Device ID: 0x0009
Product family: Datexel DAT11000 series
Main Family: I/O

Protocol implemented: PROFINET IO 
PN_IO version: v 2.44
Requires Engineering Tool which supports at least GSDML version: v 2.25

Supported RT Classes: RT CLASS 1
Conformance Class: B
Netload Class : III

Address assignment: Profinet DCP

I&M records supported: 1,2,3,5

Additional protocols supported: SNMP, LLDP, MRP (as Client)
Web Server supported: yes on Port 80 with HTTP protocol

Ethernet ports number: 2
Mautype: 16  (100BaseTXFD)

Number of slots: 3
Slot IDs: 0 (DAP) ,1 (Input Objects), 2 (Output Objects)

Cyclic data:
Number of Input bytes: 32
Number of Output bytes: 4

Parameters
Number of bytes: 6

Factory default state
Station Name: “” (empty string – not name assigned)
IP Address: 0.0.0.0
Subnet Mask: 0.0.0.0
Gateway Mask: 0.0.0.0

Structure 1: Unsigned Integer 16 bit structure :

https://www.datexel.com/profinet-io-slave-dat11130pn-4di-4relay.html
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DEVICE LEDs FUNCTION

List of LEDs
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Front LEDs layout

LED name LED state Condition Description

PWR

Off Device not powered - No Power supply voltage applied to the device

Green Device powered - Power supply voltage applied to the device

Green, blinking Device in Watchdog - Refer to Watchdog chapter

STS Off Default - Reserved

NS

Off Offline
- With PWR Off : device not power

- With PWR Green: no connection with IOC

Green Online (RUN)
 - Connection with IOC established

- IO Controller in RUN state

Green, 1 flash Online (STOP)
- Connection with IOC established

- IOC in STOP or IO data bad

Green, blinking Blink
Used by engineering tool to identify the node on the 

network

Red Fatal event Major internal error (combined with MS led red)

Red, 1 flash Station Name error Station Name not set

Red, 2 flashes IP address error IP address not set

Red, 3 flashes Configuration error
- IP address conflict

- Expected Identification differs from Real Identification

MS

Off Not Initialized
- With PWR Off : device not power

- With PWR Green : module is initializing

Green Normal operation  Correct working

Green, 1 flash Diagnostic Event Diagnostic event present

Red
Fatal event Major internal error (combined with NS led red)

Exception error Device in exception

I0
Off Digital Input 0 OFF

State of Digital Input 0
Red Digital Input 0 ON

I1
Off Digital Input 1 OFF

State of Digital Input 1
Red Digital Input 1 ON

I2
Off Digital Input 2 OFF

State of Digital Input 2
Red Digital Input 2 ON

I3
Off Digital Input 3 OFF

State of Digital Input 3
Red Digital Input 3 ON

O0
Off Digital Output 0 OFF

State of Digital Output 0
Red Digital Output 0 ON

O1
Off Digital Output 1 OFF

State of Digital Output 1
Red Digital Output 1 ON

O2
Off Digital Output 2 OFF

State of Digital Output 2
Red Digital Output 2 ON

O3
Off Digital Output 3 OFF

State of Digital Output 3
Red Digital Output 3 ON
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DEVICE LEDs FUNCTION

Ethernet LEDs layout PORT1 PORT2

List of LEDs

LED name LED state Condition Description

LED1 Off Default Not used; always in default state

LED2

Off
Link not sensed 

on Port 1

- Ethernet not connected
- Ethernet MAU Type different from 100 Mbps Full 
duplex

Green , blinking
Link / Act sensed 

on Port 1
 Correct working

LED3 Off Default Not used; always in default state

LED4

Off
Link not sensed 

on Port 2

- Ethernet not connected
- Ethernet MAU Type different from 100 Mbps Full 
duplex

Green / Blinking
Link / Act sensed 

on Port 2
 Correct working

LED 2 LED 1 LED 4 LED 3
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RESET  TYPES SUPPORTED

A factory reset command from the network is done using the Discovery and Basic Configuration Protocol (DCP). The device supports the reset modes 
2 and 8 described below. 
Behavior of the device:

• Reset  To Factory mode 2

IP Address = "0.0.0.0"
Subnet Mask = "0.0.0.0"
Gateway Address = "0.0.0.0"
DNS1 = "0.0.0.0"
DNS2 = "0.0.0.0"
Host name = NULL
Domain name = NULL
Station Name = ""
– SNMP MIB-II variables:
• sysName = empty string
• sysContact = empty string
• sysLocation = empty string
– All PDev parameters set to default values.

• Reset To Factory mode 8 and (legacy) FactoryReset

IP Address = "0.0.0.0"
Subnet Mask = "0.0.0.0"
Gateway Address = "0.0.0.0"
DNS1 = "0.0.0.0"
DNS2 = "0.0.0.0"
Host name = NULL
Domain name = NULL
Station Name = ""
– SNMP MIB-II variables:
• sysName = empty string
• sysContact = empty string
• sysLocation = empty string
– All PDev parameters set to default values.
– I&M1-3 set to default values.

NETWORK PARAMETERS ASSIGNMENT

The network parameters such as the Station Name, the IP Address, the Subnet Mask and the Gateway Mask are set using the Discovery and Basic 
Configuration Protocol (DCP), that is the protocol for PROFINET used for name and address resolution.
The data can be saved Temporally or Permanently.
If the data are saved Temporally they will be lost when the device is powered off.
If the data are saved Permanently they will be kept when the device is powered off.
All of the data are set to factory default if a command of Reset takes place. For the description see the next chapter.
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Byte
Position Description Register Type/Format Access

0 - 1 System Flags 16-bit, Unsigned RO

2 - 3 Digital Outputs readback 16-bit, Unsigned RO

4 - 5 Digital Inputs 16-bit, Unsigned RO

6 - 7 Digital Input Rise Latch 16-bit, Unsigned RO

8 - 9 Digital Input Fall Latch 16-bit, Unsigned RO

10 - 11 Low part 32 bit Counter 0 16-bit, Unsigned RO

12 - 13 High part 32 bit Counter 0 16-bit, Unsigned RO

14 - 15 Low part 32 bit Counter 1 16-bit, Unsigned RO

16 - 17 High part 32 bit Counter 1 16-bit, Unsigned RO

18 - 19 Low part 32 bit Counter 2 16-bit, Unsigned RO

20 - 21 High part 32 bit Counter 3 16-bit, Unsigned RO

22 - 23 Low part 32 bit Counter 3 16-bit, Unsigned RO

24 - 25 High part 32 bit Counter 3 16-bit, Unsigned RO

26 - 27 Power up / Safe readback 16-bit, Unsigned RO

28 - 29 Debouncing Time readback 16-bit, Unsigned RO

30 - 31 Watchdog Timeout readback 16-bit, Unsigned RO

CYCLIC INPUT DATA MAPPING

Byte
Position Description Register Type/Format Access

0 - 1 Digital Outputs 16-bit, Unsigned WO

2 - 3 Reset/Enable flags 16-bit, Unsigned WO

CYCLIC OUTPUT DATA MAPPING

Byte
Position Description Register Type/Format Access

0 - 1
Bit 0 to 7 - Powerup value / 

Bit 8 to 15 Safe value
16-bit, Unsigned WO

2 - 3 Debouncing Time as ms 16-bit, Unsigned WO

4 - 5 Watchdog Time as sec 16-bit, Unsigned WO

PARAMETERS MAPPING

WO = Write Only 
RO = Read Only
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PARAMETERS: POWER-UP / SAFE / WATCHDOG

The Power-Up (Bit 0÷7) condition sets the outputs of the device to a predefined value each time the device is powered-up. 

The Safe (Bit 0÷15) condition sets the outputs of the device to a predefined value if the IOC has established an AR with the device 
performing a cyclic communication and the link state of the Ethernet is not sensed on both the ports for the time specified in the 
Parameter “Watchdog Time as sec” or if the IOC release the AR ,goes in debug and the link state of the Ethernet is not sensed on 
both the ports for the time specified in the Parameter “Watchdog Time as sec”. 

The value of the Power-up and Safe can be read cyclically in bytes 26/27 "Power up / Safe read back" of the Input Cyclic Data.

The value of the Power-up and Safe can be set in the Parameter "Bit 0 to 7 - Powerup value / Bit 8 to 15 Safe value". See table below 
for the association of bits to the digital outputs.

The Watchdog timer is disabled and doesn’t work if the Parameter “Watchdog Time as sec” is set to 0 (default)

The Watchdog timer works if the Parameter “Watchdog Time as sec” is different from 0. The parameter is written each time the IOC 
establishes an AR with the device and it is expressed as seconds. The Watchdog bit will be set to 1 (see the description of “System 
Flags”).

The value of the Watchdog time can be read cyclically in bytes 30/31 "Watchdog Timeout Read Back" of the Input Cyclic Data.

PARAMETERS
Definitions:
IOC = Controller IO;
AR =  Application Relation: connection established between one or more IOC  and the slave devices during the startup of a 
communication process.

It is possible to set the following parameters each time the IOC establishes an AR. Each parameter can be read back in the cyclic 
input data in order to check, if desired, the value of the parameters.

Parameter’s bytes 0(L)/1(H) "Bit 0 to 7 - Powerup value / Bit 8 to 15 Safe value" – Values allowed from 0 up to 65535

Parameter’s bytes 2(L)/3(H) : “Debouncing Time as ms” – Values allowed from 1 up to 255

Parameter’s bytes 4(L)/5(H) : “Watchdog Time as sec” – Values allowed from 0 up to 255

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Out # - - - -
Out 
3

Out 
2

Out 
1

Out 
0

- - - -
Out 
3

Out 
2

Out 
1

Out 
0

Descr Safe Power-Up

PARAMETERS: DEBOUNCING TIME (MINIMUM DURATION PULSE)

The Minimum Acceptable Pulse Duration is set in this parameter so that the change of state or the counting of the counters is 
detected.
This function is applied to all of the digital inputs.
By setting this parameter, all pulses or spikes with a duration shorter than this value are “filtered”/ ignored. This allows, for example, to 
filter the spikes during the opening or closing of a mechanical contact (flow meters, litre counters, etc.) and therefore to get a “clean” 
counting in the pulse counter.
The value is expressed as milliseconds (ms).
The values must be between 1 and 254 ms.
The value 255 forces the minimum pulse duration to 50 ms.
The value of the Debouncing time can be read cyclically in bytes 28/29 "Debouncing Time readback" of the Input Cyclic Data.

EXAMPLE:
If the value written is 10, all pulses with duration shorter than 10 ms are filtered / ignored.
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BYTES 2 – 3: DIGITAL OUTPUTS READ BACK
This object allows to monitor the state of the output relays driven in the object “Digital Outputs” of the Cyclic Output Data (0 = OFF ; 
1 = ON).

BYTES 0 – 1: SYSTEM FLAGS
This object allows to retrieve the system events of the device. The following parameters are implemented.

Supervising Bits (bits 0,1,2): the combination of the values given by these 3 bits indicates the status of the device.
Bit 0 = 0;Bit 1 = 1; Bit 2 = 0; status "WAIT PROCESS": the device is waiting for being supervised by an IOC
Bit 0 = 1;Bit 1 = 1; Bit 2 = 0; status "IDLE" :the device has been supervised by an IOC but now the IOC is in STOP
Bit 0 = 0;Bit 1 = 0; Bit 2 = 1; status "PROCESS ACTIVE" :the device is supervised by an IOC 
Bit 0 = 1;Bit 1 = 0; Bit 2 = 1; status "ERROR" :the device has detected an error condition
Bit 0 = 1;Bit 1 = 1; Bit 2 = 1; status "EXCEPTION" :the device is in exception state

Watchdog Event Enable (bit 8): this bit shows if the Watchdog event is disabled (0) or enabled (1).If enabled and the IOC has 
established an AR with the device performing a cyclic communication and the link state of the Ethernet is not sensed on both the 
ports for the time specified in the Parameter “Watchdog Time as sec” or if the IOC has realeased an AR and is in debug state and 
the link state of the Ethernet is not sensed on both the ports for the time specified in the Parameter “Watchdog Time as sec”, the 
PWR led flashes and the status of the outputs is automatically set as defined in the high byte of the "PowerUp / Safe" parameter.
The “Watchdog Event Enable” bit resides in eeprom therefore, in case of power failure, it maintains its status.

Watchdog Event (bit 9): if this bit is set to 1 indicates that the Watchdog condition has occurred (0 = Normal condition; 1 = alarm 
condition) 
When the Watchdog event has occurred, this bit can be reset setting to 1 the bit 9 of the object “Reset/Enable Flags” of the Cyclic 
Output Data 

Power-Up Event (bit 10): this bit is forced to 1 at each power on and indicates that the device has been switched off. With the 
setting of this bit to 0 and checking its state, it is possible to monitor if an unexpected power-off of the device has occurred (0 = 
power-off not occurred; 1 = power-off occurred).
This bit can be reset setting to 1 the bit 10 of the object “Reset/Enable Flags” of the Cyclic Output Data .

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Descr
Watchdog Event Enable
Watchdog Event
Power-up Event

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Out # - - - - - - - - - - - -
Out 
3

Out 
2

Out 
1

Out 
0

BYTES 4 – 5: DIGITAL INPUTS
This object shows the condition of the digital inputs (0 = OFF; 1 = ON).

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

In # - - - - - - - - - - - - In 3 In 2 In 1 In 0

SLOT ASSIGNMENT: USED IN SLOT 1 , FIXED IN SUB-SLOT 1

CYCLIC INPUT DATA MAPPING

Supervising 
Bits

BYTES 6 – 7: DIGITAL INPUTS RISE LATCH
The bits of this object are used to indicate that an event of change of logic state of digital input from 0 to 1 (rise latch) has occurred . 
The latch event shows for each digital input the single change of state and is not updated by the system. It is possible to reset the 
whole object setting to 1 the bit 4 of “Reset/Enable Flags” of the Cyclic Output Data . 

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Latch - - - - - - - - - - - - In 3 In 2 In 1 In 0

BYTES 8 – 9: DIGITAL INPUTS FALL LATCH
The bits of this object are used to indicate that an event of change of logic state of digital input from 1 to 0 (fall latch) has occurred . 
The latch event shows for each digital input the single change of state and is not updated by the system. It is possible to reset the 
whole object setting to 1 the bit 5 of “Reset/Enable Flags” of the Cyclic Output Data . 

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Latch - - - - - - - - - - - - In 3 In 2 In 1 In 0
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BYTES 10 – 11 (LOW) / BYTES 12 – 13: 32 BIT COUNTER DIGITAL INPUT 0
These four bytes contains the measure of the digital counter related to the input channel 0. The value is incremented at each change 
of state from 0 to 1 of the input channel 0. The type of data created is an Unsigned Long 32 bit.
It is possible to reset the value of the counter setting to 1 the bit 0 of the object “Reset/Enable Flags” of the Cyclic Output Data.
Note: The counter is not retentive. When the device is switched off, the value contained in these bytes is lost.

BYTES 14 – 15 (LOW) / BYTES 16 – 17: 32 BIT COUNTER DIGITAL INPUT 1
These four bytes contains the measure of the digital counter related to the input channel 1. The value is incremented at each change 
of state from 0 to 1 of the input channel 1. The type of data created is an Unsigned Long 32 bit.
It is possible to reset the value of the counter setting to 1 the bit 1 of the object “Reset/Enable Flags” of the Cyclic Output Data.
Note: The counter is not retentive. When the device is switched off, the value contained in these bytes is lost.

BYTES 18 – 19 (LOW) / BYTES 20 – 21: 32 BIT COUNTER DIGITAL INPUT 2
These four bytes contains the measure of the digital counter related to the input channel 2. The value is incremented at each change 
of state from 0 to 1 of the input channel 2. The type of data created is an Unsigned Long 32 bit.
It is possible to reset the value of the counter setting to 1 the bit 2 of the object “Reset/Enable Flags” of the Cyclic Output Data.
Note: The counter is not retentive. When the device is switched off, the value contained in these bytes is lost.

BYTES 22 – 23 (LOW) / BYTES 24 – 25: 32 BIT COUNTER DIGITAL INPUT 3
These four bytes contains the measure of the digital counter related to the input channel 3. The value is incremented at each change 
of state from 0 to 1 of the input channel 3. The type of data created is an Unsigned Long 32 bit.
It is possible to reset the value of the counter setting to 1 the bit 3 of the object “Reset/Enable Flags” of the Cyclic Output Data.
Note: The counter is not retentive. When the device is switched off, the value contained in these bytes is lost.

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Out # - - - -
Out 
3

Out 
2

Out 
1

Out 
0

- - - -
Out 
3

Out 
2

Out 
1

Out 
0

Descr Safe Power-Up

BYTES 26 – 27: POWER-UP / SAFE READ BACK
This object allows to read the value set in Parameter "Bit 0 to 7 - Power-Up value / Bit 8 to 15 Safe value" (0 = bit not enabled; 1 = bit 
enabled).

BYTES 28 – 29: DEBOUNCING TIME READ BACK
This object allows to read the value set in Parameter “Digital Input Debouncing Time as milliseconds” 

BYTES 30 – 31: WATCHDOG TIMEOUT READ BACK
This object allows to read the value set in Parameter ““Watchdog Time as sec”” 
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BYTES 0 – 1: DIGITAL OUTPUTS
This object allows to drive the state of the output relays (0 = OFF ; 1 = ON).
The value of this object can be read cyclically in bytes 2/3 "Digital Outputs Read Back" of the Input Cyclic Data

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Out # - - - - - - - - - - - -
Out 
3

Out 
2

Out 
1

Out 
0

SLOT ASSIGNMENT: USED IN SLOT 2 , FIXED IN SUB-SLOT 1

CYCLIC OUTPUT DATA MAPPING

BYTES 2 – 3: RESET / ENABLE FLAGS
The set to 1 of the bits of this object allow to do the following system operations: 
- Reset counter digital input 0 (Bit 0): the value of 32 bit Counter Digital Input 0 (Cyclic Input bytes 10 - 11 - 12 - 13) will be set to 0
- Reset counter digital input 1 (Bit 1): the value of 32 bit Counter Digital Input 1 (Cyclic Input bytes 14 - 15 - 16 - 17) will be set to 0
- Reset counter digital input 2 (Bit 2): the value of 32 bit Counter Digital Input 2 (Cyclic Input bytes 18 - 19 - 20 - 21) will be set to 0
- Reset counter digital input 3 (Bit 3): the value of 32 bit Counter Digital Input 3 (Cyclic Input bytes 22 - 23 - 24 - 25) will be set to 0
- Reset Rise Latch object (Bit 4): the value of Digital Input Rise Latch (Cyclic Input bytes 6 - 7)  will be set to 0
- Reset Fall Latch object (Bit 5): the value of Digital Input Fall Latch (Cyclic Input bytes 8 - 9)  will be set to 0
- Reset Watchdog event bit (Bit 9): the value of Watchdog Event in System Flags (bit 9 Cyclic Input bytes 0 - 1)  will be set to 0
- Reset Power-Up bit (Bit 10): the value of Power-Up Event in System Flags (bit 10 Cyclic Input bytes 0 - 1)  will be set to 0

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

Descr

Reset Fall Latch object
Reset Rise Latch object
Reset counter digital input 3
Reset counter digital input 2
Reset counter digital input 1
Reset counter digital input 0

Reset Power-Up bit 
Reset Watchdog event bit 
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IMPORTING THE DEVICE IN TIA PORTAL
The following example has the purpose to show how to insert the GSDML file of the device in SIEMENS TIA PORTAL. It has been 
done using SIEMENS TIA PORTAL V17 and a PLC S7-1200; the example includes the creation of a new project using ladder.
Run TIA PORTAL and wait for the application to be executed.
Step 1: create a new project.
Click Start (A) → Create New Project (A1) → Set the name and path of the project (A2) → Click Create (A3)

Wait for the creation of the project.
Click “Configure a device” (A4)

A

A1

A2

A3

A4

Step 2: Add the PLC.
Be sure that the PLC has been powered on and connected to the network. Click Add new device (A5) → Click Controllers (A6) → 
Select the Controller from the menus (A7)

A5

A6

A7



 Page 11 of 38 

When the Controller has been selected click “Add” (A8)

A8

Follow the wizard to define the security settings editing them as required from the project. When the procedure is completed click 
“Finish” (A9)

A9

The PLC is added to the project.
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Step 3: Set PLC Network.
In the project tree click the branch of PLC (B) and after double click on “Device configuration” (B1)
Double click on PLC in the Device view of the project (B2).

B
B1

B2

The properties section appears below the project window.
Click the frame “General” (B3)
Click the branch “PROFINET Interface [X1]” (B4)
Click the branch “Ethernet addresses” (B5)
Scroll the scroll bar on the right down until you reach the section “Internet protocol version 4  (IPv4)” (B6) 
Set the value of the IP address (B7) and press Enter. In this example the IP address of PLC is set to 192.168.1.88 

B3B3

B4 B6

B5
B7

Step 4: Import the GSD file of the device in the project
Download the GSDML file of the device from the website www.datexel.it to a folder in your PC.
On the menu bar click “Options” → “Manage general station description file (GSD)” (C) 

C

The window that allow to import the GSDML file will be opened (next page) 

http://www.datexel.it/
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Click the button “…” (C1)
Select the path where the GSDML file has been downloaded

C1

In the folder selected there may be more than one GSDML file; in this case all of the files corresponding to GSDML extension in the 
folder will be listed. Select the file about the device from the list (C2)
Click “Install” (C3)

C3

C2

The system will take some time to complete the installation of the GSDML file and add it to the “Hardware catalog”.

Step 5: Add the device to the project
In the Project tree double click on the branch “Devices and networks” (D).

D

On the right of the software window some side menus will appear.
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Click on “Hardware catalog” (D1)
Click “Other field devices” (D2) 
Click “PROFINET IO” (D3)
Click “I/O” (D4)
Click “Datexel S.r.l.” (D5)
Click “Datexel DAT11000 series” (D6)
Click “dat11130pn” (D7) and drag and drop it to the project.

D1

D3

D4
D5

D6
D5

D7

The device will be added to the project.

Step 6: Link the device to PLC and configure it.
In “Devices and networks” → “Network view” right click of the mouse on the device’s symbol,label “Not assigned” (E).
Click “Assign to new IO controller” (E1)

E

E1

A window that let to select the controller will appear (next page)

D2
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E5

E6 E8

E7
E9

Select the controller (E2).
Click OK (E3). The device will be linked to PLC and its network.

E2

E3

E4

Double click on the device (E4), click the image of the device it appears (E4A).
The properties section appears below the project window.
Click the frame “General” (E5)
Click the branch “PROFINET Interface [X1]” (E6)
Click the branch “Ethernet addresses” (E7)
Scroll the scroll bar on the right down until you reach the section “Internet protocol version 4 (IPv4)” (E8) 
Set the value of the IP address (E9) and press Enter. In this example the IP address of the device is set to 192.168.1.13
Doing this, the IP parameter will be assigned in the project.

To establish a connection in PROFINET it is mandatory to assign a specific Station Name to the device otherwise it will result in a 
communication error. Scroll the scroll bar on the right down until you reach the section “PROFINET” (E10).

E10

E12

E11

If the flag “Generate PROFINET device name automatically” (E11) is checked, the default Station Name in GSDML file will be 
assigned. In PROFINET there can’t be different devices with the same Stations name. If the flag is unchecked, it is possible to assign 
the name manually (E12). When PROFINET device name is modified the software will update automatically the field “Converted 
Name”. 
After the name has been set, it is necessary to assign the name to the device.
Look for the devices connected.
In the tool bar click the icon for Accessible devices (E13) 

E13

E4A
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Before to proceed be sure that the device has been powered on and connected to the network.
Select the interface (E14) and network (E15)
Click Start search (E16)

E14E14

E15

E16

When the search for the devices connected is over, the devices will be listed and our device is included in it (E17)

Click “Cancel”, go back to “Device overview”, double click on the device dat11130pn and click on button “Assign device name” (E18)

E17

E18
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Click “Update list” (E19)

E19

When the list is filled, click on the row of the device (E20); click “Assign name” (E21)

E20

E21

When the name is assigned, the status OK appears on the row of the device (E22)

E22
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Step 7: Creation of variables and mapping to the objects.
This example is about how to map the “Digital Inputs” and “Digital Outputs” variables.
Note: for the position of the variables you want to map always refer to the previous chapters of this document.
Select the device in “Devices and Network”.
On the top right corner select “Device view” (F)
Select the row of Input Objects (F1)

F

F1

The “Digital Inputs” are mapped to the bytes 4 and 5 of the Cyclic Input Data (third position in the array).  
In the properties of Input Objects, frame IO tags (F2) in the column “Name” write the name of the variable that you want to be mapped 
in the third position of the array (F3);  in the column “Tag table” select “Default tag table” (F4).

F2

F3 F4

In “Device view” (F), select the row of Output Objects (F5)

F5
The “Digital Outputs” are mapped to the bytes 0 and 1 of the Cyclic Output Data (first position).  
In the properties of Output Objects, frame IO tags (F6) in the column “Name” write the name of the variable that you want to be 
mapped in the first position of the array (F7);  in the column “Tag table” select “Default tag table” (F8).

F8
F7

F6

In the Project tree select the PLC, select PLC tags (F9), double click on Default tag table (F10).

It will show the variables mapped (next page).

F9

F10
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Step 8: Creation of the project.
In this example it will be show a very simple project composed of a “Move” function with the purpose of moving the value on the inputs 
of the device to the outputs. Moreover, this example has also the purpose of show how to set the module parameters. 
In the Project tree under the branch of PLC select “Program blocks” (G), right click on it and select “Add new block” (G1)

G

G1

Select “Program cycle” (G2) from “Organization block” (G3) and click OK (G4).

G2

G3

G4

 It will be created an empty project.

In the Project tree, double click on the block “Main” (G5).

G5

On the right it will appear the menu “Instructions”.
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G12

G11

G6

The instruction will be added to the project.

Click “Basic Instructions”(G6) → “Move operations” (G7) →  “MOVE” (G8)

G7

G8

Click <???> IN to define the input variable (G9)
Select the variable (G10). In this example the variable is “Digital Inputs”

G10

G9

The Move instruction needs an enable bit. It can be set using any available boolean. In this example a User constant defined in the 
“Default tag table” is used. 

Click <???> OUT to define the output variable (G11)
Select the variable (G12). In this example the variable is “Digital Outputs”
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Insert an open contact in the “EN” branch and click on <??.?> to assign the variable (G13).

G13

The simple project is complete.

Step 9: Set the module parameters
The parameters allow the setting of the system functions for the device when the PLC establishes the connection with it.
All of these parameters can be monitored by means of Read back objects in Cyclic Input Data.
To set the parameters go to “Network view”, select the dat11130pn, go to “Device view”, double click on the device image.
In properties under frame “General” click “Module parameters” (H).
Set the values as desired between the limits shown (H1) and press Enter.

H

H1

Step 10: Compile the project, download it to PLC and monitor the variables
In the Project tree select the branch of PLC.
In the Toolbar click “Compile” (I)
When the project is compiled, in the Toolbar click Download to device (I1) and follow the procedure to end the download correctly.
When the download is complete, in the Toolbar click “Start CPU” (I2) and when asked by the system go in RUN mode.
In the Toolbar click “Go online” (I3).
If there are not errors all the fields related with PLC communication are marked in green.

I I1 I2I3

To monitor the variables go to PLC tag → Default tag table. Click “Monitor all” (I4)

In the column “Monitor value” (I5) is it possible to see the variables changing.

I4

I5
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IMPORTING THE DEVICE IN CODESYS

The following example has the purpose to show how to insert the GSDML file of the device in CODESYS.
It has been done using CODESYS 3.5 SP19 Patch 6 Soft PLC that includes the creation of a new project using a standard project 
template with PLC_PRG in standard text.
Run Codesys and wait for the application to be executed.

Step 1: create a new project.
Click File → New Project.

Select icon “Standard project” (A).
Edit the name of the project (A1).
Click OK (A2).
Edit the project as follows and click OK (A3).

A

A1 A2

The following screen with the basic project functions will appear. 

A3
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Step 2: Connect to PLC
This step may change in function of the PLC used. Activate the PLC.
Double click on “Device” in the tree-view of the project, click Communication Settings (B), insert the credential to access the PLC if 
required and click Scan Network (B1). Select the PLC and connect to it to obtain the following window with green marks.

B1B

Step 3: insert an Ethernet Interface.
In the tree-view of the project select and right click of the mouse on “Device (Codesys Control Win V3)” (C) .

C

Select Add Device; the following window will appear.
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Select “Fieldbuses” (D) → select “Ethernet Adapter” (D1) → Select “Ethernet” (D2). Click button “Add Device” (D3).
The branch Interface “Ethernet” will be added to the tree-view of the project (D4)

D

D1
D2

D3

D2

D4

Double click on “Ethernet” (D4). The following window appears. Click button “Browse” (D5).
Select the network interface and click button “OK” (D6).

D5

D5D6
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E

Step 4: Insert PN Controller.
In the tree-view of the project select and right click of the mouse on “Ethernet” (E)

Select “Add Device”; the following window will appear

E1

E2

E3

E4

E5

Select “Fieldbuses” (E1) → select “PROFINET IO” (E2) → Select “PROFINET IO Master” (E3) → “Select PN Controller” (E4).
Click button “Add Device” (E5).
The element “PN Controller” will be added under the branch “Ethernet” to the tree-view of the project (E6)

E6
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Set the Station name of Controller (E7)
Compatibly with the IP address of Ethernet that has been set in step 3:
set the First IP Address for the slave devices (E8) 
set the Last IP address for the slave devices (E9) 
set the Subnet Mask (E10) 
set the Gateway Mask (E11) 

E7

E8
E9
E10
E11

Step 5: Install the GSDML file of the device into Device Repository of Codesys.
Download the GSDML file of the device from the website www.datexel.it to a folder in your PC.
In the Menu bar of Codesys click “Tools” → “Device Repository…”
The following window appears.

Select “Fieldbuses” (F) → select “PROFINET IO” (F1) → Select “PROFINET IO Slave” (F2) → Click button “Install” (F3).
The window “Install Device Description” will appear; recall the path of the folder wherein you downloaded the GSDML file of the 
device, select it and click “Open” (F4) (next page).

F3

F2

F1

F

F7

http://www.datexel.it/
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The file will be installed under the folder “I/O” (Main family of the device). If it is the first time that a Datexel’s device is installed, 
Codesys will create the folder “Datexel DAT11000” (F5), otherwise the device’s GSDML will be added inside it. Select the file installed 
(F6) and click “Close” (see previous page - F7) on Device Repository window.

F5

Step 6: Scan the network for the device and add it to the project.
In the Menu bar of Codesys click “Build”→ “Clean” and after click “Build”→ “Generate Code”.
Once the project has been compiled in the Menu bar of Codesys click “Online”→ “Login” to login to the PLC.
In the tree-view of the project right click of the mouse on the element “PN Controller”.
Check that the device has been powered-on and that the Ethernet cable is connected to Port1 or Port2. 
Select “Scan for Devices”. The below window will appear, the system takes some seconds and the device will be listed.

Being provided as Factory default the device is supplied with communication parameters not set.
To import the device in the project it is necessary set them as follows.
Select the row of the device (G)
Edit the Station Name in the proper column (G1); example: “dat11130pn”
Edit the Network Parameters in the proper columns (G2); example: IP Address:”192.168.1.13” Subnet Mask: “255.255.255.0” Gateway 
Mask:”192.168.1.1”
Click “Set Name and IP” (G3) and wait for the end of operation.
Click “Scan Devices” (G4). The below window will appear and after some seconds the device will be listed and updated.

G G1
G2

G3

G4

F6

F4
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G6

G5

To import the device in the project select the row of the device (G5) and click “Copy to project” (G6).
The device will be added to the tree-view of the project as a branch of the element “PN Controller”.
In the Menu bar of Codesys click “Online”→ “Logout”.

Step 7: Create project and variables and map them to Process Data Objects.
The purpose of the simple project of this example is to repeat the value of the inputs of the device to its outputs.
In the tree-view of the project double click on “PLC_PRG” (H) 
In “PLC_PRG” define the input and output variables under “VAR” (H1)
Write the code of project (H2).

H

H2

H3

H1

Double click on the line of the DAP icon of the device (H3).
In the window that will appear it is possible to set the parameters of the device that are not included in the cyclic Process Data 
Objects. These parameters will be set each the PLC establishes an AR 
See next page.

H4
H5
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Click “General” (H6)

H7

Edit the desired values of the parameters writing them within limits in the column “Value” of each row (H7).
To map the “Digital Inputs” object double click on the line dat11130pn_1 (Input Objects) - (H4)  in the tree-view of the project.
Click “PNIO Module I/O Mapping” (H8). Double click on the line of the object to map, in this example “Digital Inputs” (H9).
The window Input Assistant appears. Click on the variable to be mapped (H10).
Click “OK” (H11). The object will be associated to the variable

H6

H8

H9

H10

H11
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Input mapped.

To map the output object double click on the line dat11130pn_2 (Output Objects) - (H5) in the tree-view of the project.
Click “PNIO Module I/O Mapping” (H12). Double click on the line of the object to map, in this example “Digital Outputs” (H13).
The window Input Assistant appears. Click on the variable to be mapped (H14).
Click “OK” (H15). The object will be associated to the variable

H12

H13

H14

H15

Output mapped.
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Step 8: run the project.
After the mapping of variables is complete, it is necessary to define the communication cycle time.
In the tree-view of the project double click on the element “Profinet Communication Task” (I) 
Define the interval of execution as milliseconds (I1)

I

I1

in the Menu bar of Codesys click “Build”→ “Clean” and after click “Build”→ “Generate Code”.
When the project has been compiled in the Menu bar of Codesys click “Online”→ “Login” to login to the PLC.
Click “Debug”→ “Start”. If the communication ends correctly the project tree looks like as follows with all green marks. 

Clicking on PLC_PRG, it will be possible to see the variables changing.
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The device is supplied by default with the IP address set to 0.0.0.0. Therefore it is not possible to access the web-server with an “out 
of the box” device. It is necessary to assign to the device a valid IP address.
To do it, before to run the web browser:
- assign via PROFINET DCP a valid IP address and Subnet Mask
- tip in the address bar of the web browser the device’s IP address. It will appear the Home page
For the devices using PROFINET the web server is intended for visualization only. 
Due to this there won’t be required any credentials to access it.
Depending on the Web browser in use some icons and/or graphics may appear with little variation in shape and colour. The supported 
web browsers are: Chrome, Firefox, Opera and Edge.

WEB-SERVER 

The “Home page” is composed of:
- Language selection to access the page with the menus of the device selected (A). Once the language has been selected the 
Network Parameters page will appear
- Link to the Datexel social media (A1) 
- Link to the Datexel web site  “www.datexel.it” (A2)  .

A

A1

A

A2

Home page

http://www.datexel.it/
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Network ParametersNetwork Parameters

The “Network Parameters page” is composed of:
- Indication of the device connected (B).
- Menu selection (B1) 
- List of Network Parameters (B2)
Indication of the device connected (B)
This label indicates the Order Number of the device connected. It is a parameter common for all of the pages available with the 
exception of the Home Page therefore it will be described only here.
This parameter doesn’t correspond to the Station Name of the device. 
Menu Selection (B1)
These buttons are common for all of the pages available with the exception of the Home Page therefore they will be described only 
here.
The green background on the button shows which is the page currently visualized. Mouse click on a button recalls a specific menu.
The list of the menu is the following:
- Network Parameters: it shows the main network settings of the device 
- Module Information: it shows the main information about the device
- Digital Inputs: it shows the status of digital inputs, the value of debouncing time and the value of the input counters.
- Digital Outputs: it shows the status of digital outputs, Power-up, safe and Watchdog.
- Home: allows to go back to the Home Page.
Network Parameters (B2)
The list of Parameters shown is the following
- IP Address: visualizes the unique IP address value assigned to the device.
- Subnet Mask: visualizes the Subnet Mask value assigned to the device.
- Gateway Mask: visualizes the Gateway Mask value assigned to the device. 
- Ethernet Port 1 / Ethernet Port 2 : visualize the status of connection for Ethernet Port 1 and Ethernet Port 2. The status shown are:
No link: it means there is not a connection sensed on the port indicated.
100 Mbit: it means there is a connection sensed on the port indicated.
- MAC address: visualizes the unique MAC address value of the device

B

B1

B2
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The “Module Information page” is composed of:
- Indication of the device connected (C).
- Menu selection (C1) 
- Overview of the Device main information (C2)  
- Button Refresh (C3).
Information (C2)
- Module Name: shows the device name of the device connected. This parameter doesn’t correspond to the Station Name of the 
device. 
- Vendor ID: shows the unique Vendor ID assigned to Datexel S.r.l. by PI association 
- FW version: shows the firmware version of the device 
- Web version: shows the version of the web server
- Vendor Name: shows the vendor name (Datexel S.r.l.)  
- Module Status: shows the current status of the device; refer to section CYCLIC INPUT DATA MAPPING – Bytes 0/1 – System Flags 
- Supervising Bits for the description of values.
- Protocol: shows the communication protocol (PROFINET IO)
- PowerUp Event: shows the status of PowerUp bit (red: PowerUp event detected – gray: PowerUp event reset ) 
- Uptime: shows the time elapsed since the moment the device was powered up. 
Refresh (C3)
The button allows to refresh the parameters of this page reading them from the device.

Module Information

C

C1

C2

C3
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The “Digital Inputs page” is composed of:
- Indication of the device connected (D).
- Menu selection (D1) 
- Column of Digital Inputs (D2)  
- Column of Digital Inputs State (D3)  
- Column of Digital Inputs Rise Latches (D4) 
- Column of Digital Inputs Fall Latches (D5)   
- Column of Digital Inputs Counters (D6)  
- Debouncing Time (D7)  
- Functional buttons (D8)
Column of Digital Inputs (D2)
Divided by rows per each input shows the status of the digital input channel. 
Column of Digital Inputs State (D3)
Divided by rows per each input shows the status of the digital input (red: Input state 1 – gray: Input state 0 ) .
Column of Digital Inputs Rise Latches (D4)
Divided by rows per each input shows if a rise latch event for the specific digital input has occurred (checked: event occurred – 
unchecked: event not occurred ).
Column of Digital Inputs Fall Latches (D5)
Divided by rows per each input shows if a fall latch event for the specific digital input has occurred (checked: event occurred – 
unchecked: event not occurred ).
Column of Digital Inputs Counters (D6)
Divided by rows per each input shows the value of the counter associated to the specific digital input.
Debouncing Time (D7)
Shows the value in ms of the Debouncing Time.
Functional buttons (D8)
Contains the buttons to perform the communication;
Read: single read command sent to the device.
Continuous reading: continuos read command sent to the device.
Stop: stop the reading from the device if a continuos read command has been previously sent.

Digital Inputs

D

D1

D8

D2
D3 D4 D5 D6

D7
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The “Digital Outputs page” is composed of:
- Indication of the device connected (E).
- Menu selection (E1) 
- Column of Digital Outputs (E2)  
- Column of Digital Outputs State (E3)  
- Column of Digital Outputs PowerUp (E4) 
- Column of Digital Outputs Safe (E5)  
- Watchdog Alarm (E6)    
- Watchdog Timeout (E7)   
- Refresh button (E8)
Column of Digital Outputs (E2)
Divided by rows per each output shows the status of the digital output channel. 
Column of Digital Outputs State (E3)
Divided by rows per each output shows the status of the digital output (red: output activated – gray: output not activated ) .
Column of Digital Outputs PowerUp (E4)
Divided by rows per each output shows the setting to which the specific digital output will be forced to when a Powerup event occurs 
(checked: output will be set to state 1 – unchecked: output will be set to state 0 ).
Column of Digital Outputs Safe (E5)
Divided by rows per each output shows the setting to which the specific digital output will be forced to when a Safe event occurs 
(checked: output will be set to state 1 – unchecked: output will be set to state 0 ).
Watchdog Alarm (E6)
Shows if a Watchdog alarm has occurred (checked: event occurred – unchecked: event not occurred ).
Watchdog Timeout (E7)
Shows the value in seconds of the Watchdog Timeout; a value of 0 means that the functionality is disabled.
Refresh (E8)
The button allows to refresh the parameters of this page reading them from the device.

Digital Outputs

E

E1

E7

E2
E3 E4 E5

E6

E8
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The following additional commands can be used to identify which network the PC is connected to.
To use the following commands, run the Command Prompt (cmd.exe) as Administrator (Pict.1).
Before trying to establish a communication with the device, the user must be sure that the parameters of subnet and network have already been 
assigned via PROFINET DCP and match the ones of the network in use.

"Ipconfig" command
It is possible to display the networks available on the PC by typing this command and pressing Enter.
The system will return a list of all the PC networks (Pict.2).
 
"Ping" command
Once the IP Address has been set, to verify if a device is connected to the network, you can use the "ping" command which is an administration utility 
for computer networks used to measure the time expressed in milliseconds of one or more packets to reach a network device and return origin.
To use the command type the command "ping" followed by the IP address of the device and press Enter.
Example:
ping 192.168.1.100

If the device is connected, the system will return the response from the device with the IP address used (Pict.3).
If the system returns the "Destination host unreachable" message, the device is not connected to the network in use.
In this case, it is suggested to check the assignment of the network parameters.

Pict. 1 Pict. 2

Pict. 3

ADDITIONAL COMMANDS TO IDENTIFY THE NETWORK IN USE



Datexel s.r.l. reserves its right to modify the characteristics of its products totally or in part without warning at any time .

 Page 38 of 38 

ED.10.24 REV.00

5) Change parameters and click OK.

3) Change Adapter Settings → select the interested network → 

right click → Properties

This example shows how to change the IP of the Personal Computer (the graphics and the procedure change in relation to the operating system in 
use) in order to allow the search for the device over the network. To do this a valid IP address must have been assigned to the device.

 1) Access to Control Panel → Network and Sharing Center 

2) Network and Sharing Center → Change Adapter Settings 

4) Properties →  Internet Protocol version 4 → Properties

EXAMPLE TO CHECK WINDOWS ® CONFIGURATION
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